发新话题
打印

立宇泰ARMSYS6410开发板启动问题

立宇泰ARMSYS6410开发板启动问题

各位大神,我的ARMSYS6410开发板,以前用的好好的,突然出现进不来系统的问题了?


情况如下:系统安装的是Wince 6.0,上电后液晶上出现Wince的启动界面,启动进度调也走动,但是进度条走到最右边后就停在那里了,而且是一直停在那里。按开发板上的那些功能按键没有反应。大神们谁知道这是怎么了?


 


下面是启动信息:


 


 


WinCE 6.0 Stepldr for ARMSYS6410 - Nandboot for 667M V0.1(090826)


Launch Eboot...



Microsoft Windows CE Bootloader Common Library Version 1.4 Built Nov  9 2009 17:34:01
Microsoft Windows CE Bootloader for ARMSYS6410 by liyutai Version V0.1 Built Nov  9 2009


[Eboot] ++InitializeDisplay()
[Eboot] --InitializeDisplay()
+OALArgsInit()
SocID:0x36410101
Arguments area is initialized
-OALArgsInit()
INFO: (unsigned)C_IsrHandler : 0x8004A68C
INFO: (unsigned)ASM_IsrHandler : 0x8004CAD0
INFO: (unsigned)pISR : 0xEA0132AC
BP_Init
[FMD] ++FMD_Init() ****
[FMD:INF] FMD_Init() : Read ID = 0x0000ecda
[FMD] FMD_Init() : NUM_OF_BLOCKS = 2048
[FMD] FMD_Init() : PAGES_PER_BLOCK = 64
[FMD] FMD_Init() : SECTORS_PER_PAGE = 4
[FMD] --FMD_Init()
[FMD] FMD_GetInfo() : NUMBLOCKS = 2048(0x800), SECTORSPERBLOCK = 64(0x40), BYTESPERSECTOR = 2048(0x800)
[FMD] FMD_GetInfo() : NUMBLOCKS = 2048(0x800), SECTORSPERBLOCK = 64(0x40), BYTESPERSECTOR = 2048(0x800)
wNUM_BLOCKS : 2048(0x800)
Press [ENTER] to launch image stored on boot media, or [SPACE] to enter boot monitor.


Initiating image launch in 0 seconds.


Launching image from boot media ...
OEMPlatformInit: IMAGE_TYPE_RAMIMAGE
RAM image
RAM image
IsValidMBR: MBR sector = 0x180 (valid MBR)
OpenPartition: Partition Exists=0x1 for part 0x21.
BP_SetDataPointer at 0x0
**[Eboot] BP_ReadData***
ReadData: Start = 0x0, Length = 0x1959800.
Log2Phys: Logical 0x1c0 -> Physical 0x340
Loading Kernel


System ready!
Preparing for download...
INFO: *** Device Name 'SMDK64100' ***
INFO: Using static IP address 0000.
INFO: Using subnet mask 2525250.
waitforconnect
INFO: using TOC[1] dwJumpAddress: 0x80107674
INFO: OEMLaunch: Jumping to Physical Address 0x50107674h (Virtual Address 0x80107674h)...



Windows CE Kernel for ARM (Thumb Enabled) Built on Sep 25 2009 at 11:04:23
******************************************
WINCE6.0 BSP Updated for ARMSYS6410 board
Version 0.1 (09-08-26)


OEM:      HangZhou LIYUTAI
Web:      http://www.hzlitai.com.cn
Phone:    86-571-56763523/25/26/
Mail:     lyt_tech@yahoo.com.cn
******************************************
[OAL] ++OEMInit()
[OAL] S3C6410_APLL_CLK   : 1332000000
[OAL] ARMCLK : 666000000
[OAL] HCLK   : 133200000
[OAL] PCLK   : 66600000
[OAL] InitializeGPIO()
[OAL] InitializeCLKSource()
[OAL] InitializeCLKGating()
[OAL] InitializeBlockPower()
DCache: 128 sets, 4 ways, 32 line size, 16384 size
ICache: 128 sets, 4 ways, 32 line size, 16384 size
+OALArgsInit()
Arguments area has some values
-OALArgsInit()
+OALTimerInit( 1, 33299, 0 )
[OAL] --OEMInit()
[FMD] FMD_OEMIoControl() : IOCTL_FMD_GET_INTERFACE
[FMD] ++FMD_Init() ****
[FMD:INF] FMD_Init() : Read ID = 0x0000ecda
[FMD] FMD_Init() : NUM_OF_BLOCKS = 2048
[FMD] FMD_Init() : PAGES_PER_BLOCK = 64
[FMD] FMD_Init() : SECTORS_PER_PAGE = 4
[FMD] --FMD_Init()
[FMD] FMD_GetInfo() : NUMBLOCKS = 2048(0x800), SECTORSPERBLOCK = 64(0x40), BYTESPERSECTOR = 2048(0x800)
[FMD:ERR] FMD_OEMIoControl() : Unknown IOCTL (0x00071c24)
[OAL] Not Clear Storage
[OAL] Not Clear System Hive
[OAL] Not Clear User Hive
[OAL] Not Clear System Hive
WARN: OALIoCtlHalGetHWEntropy: Buffer too small
DEBUG: CreateSerialObject 2
DEBUG: CreateSerialObject 1
#### IOMapped is 0 ####
Atapi!IDE_Init> Mapped IRQ(84 29) to SysIntr for primary channel of device(Drivers\BuiltIn\6410_CF)
[CF-ATA] Mode : Direct Mode
[CF-ATA] Mode :m_dwOPMode == DirectMode
[CF-ATA] Mode : using EINT2 to contrl VDD_CF
[CF-ATA] GPPCON=2aaaaaaa
Exception 'Undefined Instruction' (1): Thread-Id=00a10002(pth=85e72654), Proc-Id=00400002(pprc=81a69308) 'NK.EXE', VM-active=00400002(pprc=81a69308) 'NK.EXE'
PC=81a6b704(???+0x81a6b704) RA=80124bc8(kernel.dll+0x00013bc8) SP=d02fe038, BVA=00000000

[ 本帖最后由 zhguyi321 于 2015-1-28 20:52 编辑 ]

TOP

大家看看,是不是NandFlash出问题了?

TOP

找到问题了,技术人员的回复真慢!!!!!!

TOP

发新话题